Cookies helfen uns bei der Bereitstellung des IMT HilfeWikis. Bei der Nutzung vom IMT HilfeWiki werden die in der Datenschutzerklärung beschriebenen Cookies gespeichert.Weitere Informationen

Jupyter - Anleitung fuer Lehrende

IMT HilfeWiki - das Wiki
Jupyter - Anleitung fuer Lehrende /
Version vom 7. Oktober 2022, 09:26 Uhr von Jnk (Diskussion | Beiträge)$7

Wechseln zu:Navigation, Suche
Anleitung
Allgemeine Informationen
Informationen
Betriebssystem Alle
Service Jupyter
Interessant für Angestellte, Studierende und Gäste
HilfeWiki des IMT der Uni Paderborn
no displaytitle found: Jupyter - Anleitung fuer Lehrende

In Jupyter können Notebooks erstellt und bearbeitet werden, die die Entwicklung, Dokumentation und Ausführung von Code, Visualisierungen und erläuternden Text enthalten können. Zum allgemeinen Arbeiten mit Notebooks und Erklärungen zu allen Funktionen siehe Anleitung zu JupyterHub.

Jupyter kann auch dazu verwendet werden, um über nbgrader und Formgrader Aufgaben für Studierende zu erstellen und zu bewerten.
nbgrader ist ein Tool, das die Erstellung und Bewertung von Aufgaben im Jupyter-Notebook erleichtert. Es ermöglicht Lehrenden mittels der Formgrader-Erweiterung die einfache Erstellung von Notebook-basierten Aufgaben, die sowohl Codierübungen als auch freie schriftliche Antworten beinhalten können. nbgrader bietet außerdem die Möglichkeit zur schnellen Benotung von Aufgaben.

Kurserstellung und Kursverwaltung

Kursbeantragung

Um einen Kurs in Jupyter zu erstellen, kontaktieren Sie das IMT (imt(at)upb(dot)de). Nachdem man Sie als Kursleiter (Instructor) zugewiesen hat, können Sie den Kurs verwalten und selbst weitere Teilnehmer*innen zum Kurs hinzufügen.

Zur Kursbeantragung werden die folgenden Informationen benötigt:

  • Course ID (Kurstitel)
  • Instructor ID (IMT-Account-ID)
  • Instructor first Name (Vorname der Lehrenden)
  • Instructor last name (Nachname der Lehrenden)
  • Instructor email address (E-Mail der Lehrenden)

Kursverwaltung

Erste Schritte
Legen Sie für jeden Ihrer Kurse einen eigenen Ordner im „File Browser“ anlegen. Der Name dieses Ordners muss der Kurs-ID entsprechen! In diesem Ordner werden automatisch alle Aufgaben und Bewertungen für den Kurs gespeichert.

Im File Browser (HomeverzeichnisPersönlicher Bereich für Benutzer im Netzwerkspeicher der Universität Paderborn. Standardgröße 1 GB, im Bedarfsfall erweiterbar.) muss außerdem eine Python-Datei mit dem Titel „nbgrader_config.py“ angelegt werden (über Klick auf das Plus -> Other -> Python File; oder Rechtsklick im File Browser -> New File).

Dies hat folgenden Grund: Formgrader kann nicht mehrere Kurse gleichzeitig unterstützen. So können nur Aufgaben für einen Kurs nach dem anderen erstellt werden. Der Erweiterung Formgrader muss also in Jupyter mitgeteilt werden, in welchem Kurs Sie gerade arbeiten wollen, indem Sie explizit eine Kurs-ID in nbgrader_config.py zuweisen.

Dafür kopieren Sie folgende Befehle in die Python-Datei:
c.CourseDirectory.course_id='mycourseid'
c.CourseDirectory.root=f'./{c.CourseDirectory.course_id}/'

Ersetzen Sie 'mycourseid' durch die ID des Kurses, den Sie verwalten möchten.
Wenn Sie mehrere verschiedene Kurse besitzen, müssen Sie die Kurs-ID in der Datei nbgrader_config.py ändern, um Formgrader für verschiedene Kurse verwenden zu können. Sie müssen nach jeder Änderung jedes Mal Ihren Notebook-Server neu starten!
Weitere Informationen finden Sie auf der ngshare-Website.


Bild: 1 nbgrader_config.py Datei
Hinzufügen von Studierenden Verwenden Sie nicht Formgrader, um Studierende hinzuzufügen, da dies zu Problemen bei der Aktualisierung mit ngshare führt!

Bitte verwenden Sie die im folgenden aufgeführten Befehle (das ngshare-course-management tool), wenn Sie Studierende zu einem Kurs hinzufügen oder aus einem Kurs entfernen.


Hinweis: Da die Jupyter-Erweiterung Formgrader nur lokal für Lehrende läuft, werden Aufgaben und deren Bewertung und Feedback in Kursen nur lokal gespeichert. Daher ist keine Synchronisation zwischen mehreren Lehrenden möglich.

Hinzufügen einzelner Studierender
Um einen Studierenden zu einem Kurs hinzuzufügen, müssen die untenstehenden Befehle im Terminal im JupyterHub eingegeben werden. Ein Terminal kann im Notebook Dashboard über den Reiter File Browser -> Klick auf das Plus „New Launcher“ aufgerufen werden.

Um einen Studierenden zu einem Kurs hinzuzufügen, führen Sie folgenden Befehl aus:
ngshare-course-management add_student COURSE_ID STUDENT_ID

Dadurch wird der Studierende sowohl zu ngshare als auch zum lokalen nbgrader-Gradebook hinzugefügt. Course-ID entspricht dem Kursnamen. Die Student-ID ist der JupyterHub-Benutzername des Studierenden (Uni-AccountDer nach der erfolgreichen Immatrikulation (Studierende) oder Anstellung (Angestellte) beim IMT erstellte Zugang.).

Sie können auch -f FIRST_NAME, -l LAST_NAME und -e EMAIL für den Studierenden angeben(siehe unten). Falls der Studierende bereits existiert, werden der Name und die E-Mail-Adresse aktualisiert. Wenn Sie den Studierenden nicht zum lokalen nbgrader-Gradebook hinzufügen möchten, können Sie --no-gb angeben.

Hinzufügen einzelner Studierender:
ngshare-course-management add_student COURSE_ID STUDENT_ID

Hinzufügen einzelner Studierender mit zusätzlichen Informationen:
ngshare-course-management add_student COURSE_ID STUDENT_ID -f FIRST_NAME -l LAST_NAME -e EMAIL

Bild: 2 Hinzufügen von Studierenden im Terminal
Hinzufügen mehrerer Studierender Um mehrere Studierende auf einmal hinzuzufügen, erstellen Sie eine CSV-Datei mit dem folgenden Inhalt:
student_id,first_name,last_name,email

Die Kopfzeile muss student_id,first_name,last_name,email lauten.

Danach geben Sie die Studierenden in einer Zeile nacheinander ein. Sie können den Vornamen, den Nachnamen und/oder die E-Mail-Adresse bei Bedarf weglassen, aber es sollten 3 Kommas pro Zeile stehen (z. B. ist student,,, ein Student ohne Namen oder E-Mail-Adresse).

Ein Beispiel für die CSV-Datei wäre:
student_id,first_name,last_name,email
maxm, Max, Mustermann, max@mail.de
test, Tessa, Testerin, test@mail.de
student,,,

Nachdem Sie die CSV-Datei erstellt haben, führen Sie folgenden Befehl im Terminal aus:
ngshare-course-management add_students COURSE_ID PATH_TO_CSV_FILE

Dadurch werden die Studierenden auch dem lokalen nbgrader-Gradebook hinzugefügt. Wenn Sie dies nicht wünschen (nur Studierende zu ngshare hinzufügen, nicht zum Gradebook), können Sie --no-gb angeben.

Entfernen von Studierenden
Um Studierende aus einem Kurs zu entfernen, führen Sie diesen Befehl im Terminal aus.
ngshare-course-management remove_students COURSE_ID STUDENT [STUDENT ...]

Ersetzen Sie COURSE_ID durch Ihre Kurs-ID und STUDENT durch den Benutzernamen vom Uni-AccountDer nach der erfolgreichen Immatrikulation (Studierende) oder Anstellung (Angestellte) beim IMT erstellte Zugang. des Studierenden. Sie können mehrere Studierende in demselben Befehl angeben. Dadurch werden die Studierenden sowohl aus ngshare als auch aus dem lokalen nbgrader-Gradebook entfernt.

Liste aller Studierenden
Eine Liste aller Studierenden im Kurs kann über das Hub Control Panel (File -> Hub Control Panel, Services -> ngshare) abgerufen werden. Unter List course students kann die Kurs-ID eingegeben werden und per Klick auf Get students werden alle Studierenden des Kurses angezeigt.

Bild: 3 Liste der Studierenden im Hub Control Panel


Erstellen von Aufgaben in Formgrader

Das Erstellen von Aufgaben und das Bewerten dieser erfolgt über die nbgrader und die Formgrader-Erweiterung (über den Reiter Formgrader). Um mit Aufgaben in Kursen arbeiten zu können, benötigen Sie einen Ordner mit dem Namen des Kurses und eine konfigurierte nbgrader_config.py-Datei. Befolgen Sie dazu die Schritte unter „Erste Schritte“.

Zugriff auf die Formgrader-Erweiterung

Um Zugriff auf die Formgrader-Erweiterung zu bekommen, muss vom Hub aus auf die klassische Ansicht von Jupyter Notebook gewechselt werden. Dies kann über das Menü Help -> Launch Classic Notebook erreicht werden.

Bild: 4 Zugriff auf die klassische Ansicht von Jupyter Notebook

Ein neuer Tab mit der klassischen Ansicht öffnet sich. Hier befinden sich die Reiter „Files“, „Running“, „Clusters“, „Formgrader“, „Courses“ und „Assignments“:

  • Die Reiter "Files und Running" entsprechen dem Dashboard aus dem JupyterHub (siehe Anleitung zu JupyterHub).
  • Unter dem Reiter "Formgrader" kann die Erweiterung zum Erstellen, Verbreiten und Bewerten von Aufgaben für Studierende genutzt werden.
  • "Courses" zeigt eine Übersicht aller Kurse.
  • "Assignments" listet alle Aufgaben auf, die erstellt wurden und unterteilt dabei in "Released assignments" (Veröffentlichte Aufgaben), "Downloaded assignments" (Heruntergeladene Aufgaben) und "Submitted assignments" (Abgegebene Aufgaben).


Bild: 5 Ansicht Classic Notebook


Erstellen von Aufgaben mit Formgrader

Um eine neue Aufgabe zu erstellen, wird die Formgrader-Erweiterung verwendet. Dazu klicken Sie auf den Reiter „Formgrader“ und die Übersicht „Manage Assignments“ öffnet sich.

In der Übersicht „Manage Assignments“ werden alle erstellten Aufgaben gelistet.

Bild: 6 Funktionen im Reiter "Manage Assignments"

  • Mit Klick auf den Namen der Aufgabe (1) kann die unveröffentlichte Version der Aufgabe bearbeitet werden.
  • Falls angegeben findet sich hier die Frist für die Aufgabe (2).
  • (3) zeigt den Status der Aufgabe an.
  • Unter „Edit“ (4) können die Metadaten der Aufgabe (Name, Frist) bearbeitet werden.
  • „Generate“ (5) generiert eine Version der Aufgabe, die die Studierenden erhalten werden (im folgenden auch Release-Version oder Studierendenversion genannt).
  • Unter „Preview“ (6) kann sich eine Vorschau-Version angesehen werden.
  • „Release“ (7) veröffentlicht die fertige, generierte Version der Aufgabe und kann so von den Studierenden bearbeitet werden.
  • Mit „Collect“ (8) werden alle Abgaben von Studierenden automatisch gesammelt.
  • Die Abgaben von Studierenden können sich unter „Submissions“ (9) angesehen und bewertet werden.
  • Bei „Generate Feedback“ (10) werden HTML-Dateien im lokalen Verzeichnis des Lehrenden erstellt.
  • Bei „Release Feedback“ (11) werden diese HTML-Dateien in den nbgrader-exchange kopiert und an die Studierenden weitergeleitet.


Über die Schaltfläche „Add new assignment...“ kann eine neue Aufgabe hinzugefügt werden. Daraufhin muss der Namen der Aufgabe angegeben werden. Angaben wie bspw. das Fälligkeitsdatum sind optional. Mit einem Klick auf „Save“ werden diese Angaben gespeichert. Unter „Edit“ können diese Angaben im Nachhinein noch geändert werden.

Bild: 7 Hinzufügen einer neuen Aufgabe

Bild: 8 Erstellen einer neuen Aufgabe

Nachdem eine Aufgabe erstellt wurde, wird mit Klick auf den Namen der Aufgabe ein neuer Tab geöffnet, der im „File Browser“ das Verzeichnis der Aufgabe öffnet. Das Verzeichnis der Aufgabe wird automatisch im Kursordner angelegt, in dem die Aufgabe erstellt wurde (siehe Erste Schritte). Hier können Aufgaben in Form von Dateien wie bspw. ein Notebook angelegt werden oder bereits existierende Dateien hinzugefügt werden. Hinweis: Die Aufgaben sollten immer im dementsprechenden Ordner gespeichert werden.

Um in einem Notebook einzelne Aufgaben zu erstellen, die Studierende lösen sollen, muss zunächst die Create Assignment-Toolbar aufgerufen werden. Über das Menü View -> Cell Toolbar -> Create Assignment kann die Toolbar aufgerufen werden. Diese Toolbar markiert die Zellen des Notebooks als bspw. manuell zu bewertende Aufgabe, automatisch bewertete Aufgabe oder als schreibgeschützt.

Bild: 9 Aufrufen der "Create Assignment" Toolbar

Durch die Toolbar erscheint in jeder Zelle ein Drop Down-Menü:

Bild: 10 Drop Down Menü der "Create Assignment" Toolbar

Standardmäßig ist in jedem Dropdown-Menü das Element - ausgewählt. Die Menü-Optionen unterscheiden sich für Markdown-Zellen und Code-Zellen.

Für Markdown-Zellen gibt es drei Optionen zur Auswahl, entweder „Manually graded answer”, „Manually graded task” oder „Read-only”. Für Code-Zellen stehen fünf Optionen zur Auswahl, darunter „Manually graded answer“, „Manually graded task“, „Autograded answer“, „Autograder tests“ und „Read-only“.
Bild: 11 Optionen der "Create Assignment" Toolbar für Zellen


„Manually graded answer“ Zelle

Die Option „Manually graded answer“ (verfügbar sowohl für Markdown- als auch für Code-Zellen) markiert die Zelle als eine manuell zu bewertende Antwort.

Der häufigste Verwendungszweck für diese Art von Zelle sind frei formulierte Antworten (z. B. solche, die die Ergebnisse von Code interpretieren).

Zusätzlich muss angegeben werden, wie viele Punkte für die Antwort vergeben werden sollen. Studierenden wird in diesen Zellen ein Code oder Text angezeigt, der anzeigt, dass sie ihre Antwort oder Lösung dort eingeben sollen:

Bild: 12 Beispiel: Manuell bewertete Antwort (Ansicht Lehrende)

13 Beispiel: Manuell bewertete Code-Zelle (Ansicht Studierende)


„Manually graded task“ Zelle

Wenn die Option „Manually graded task“ ausgewählt wird, markiert die nbgrader-Erweiterung diese Zelle als eine Zelle, die die Beschreibung einer Aufgabe enthält, die die Studierenden ausführen müssen. Sie müssen manuell benotet und eine Punktzahl muss festgelegt werden.

Der Unterschied zwischen der „Manually graded task“ (manuell bewertete Aufgabe) und der „Manually graded answer“ (manuell bewertete Antwort) besteht darin, dass die Zellen für manuell bewertete Aufgaben von Studierenden nicht bearbeitet werden. Dies heißt, dass bei einer „Manually graded answer“ Zelle die Studierenden dazu aufgefordert sind, eine Aufgabe in der Zelle zu lösen. Bei einer „Manually graded task“ werden die Studierenden aufgefordert, eine Aufgabe mit Zellen auszuführen. Dies wird z.B. verwendet, wenn Studierende selbst Zellen zur Beantwortung einer Aufgabe erstellen müssen.

Bild: 14 Beispiel: Manuell bewertete Aufgabe


„Autograded answer“

Wenn die Option „Autograded answer“ (nur für Codezellen verfügbar) gewählt wird, wird die in der Zelle enthaltenen Antwort automatisch bewertet.

Wie die nächste Abbildung zeigt, können durch eine spezielle Syntax wie ### BEGIN SOLUTION und ### END SOLUTION angegeben werden, ab welcher Stelle die Studierenden ihre Lösung angeben sollen. Somit stellt der Bereich zwischen dieser Syntax den Lösungsbereich dar. Code außerhalb dieser Syntax wird den Studierenden in der Aufgabe angezeigt. Dies kann dazu genutzt werden, wenn bspw. der Beginn eines Codes vorgegeben soll:

Bild: 15 Beispiel: Automatisch bewertete Antwort aus Sicht des Lehrenden

Bild: 16 Beispiel: Automatisch bewertete Antwort aus Sicht der Studierenden

Wenn diese spezielle Syntax nicht verwendet wird, wird Studierenden nur # YOUR CODE HEREangezeigt.

Im Gegensatz zu manuell bewerteten Antworten werden für automatisch bewertete Antworten keine Punkte festgelegt. Die Punktevergabe erfolgt mittels der „Autograder tests“ Zellen, die diese Antworten bewerten.


„Autograder tests” Zelle

Die als „Autograder tests” markierten Zellen (nur für Code-Zellen verfügbar) enthalten Tests, die während des automatischen Bewertungsprozesses ausgeführt werden und so zur Kontrolle und Bewertung der automatisch bewerteten Aufgaben dienen. Im Prinzip dient dies als eine Kontrollinstanz, die den Code der Studierenden auf Funktion prüft.

Für die Zelle muss eine Punktzahl festgelegt werden. Eine Zelle erhält die volle Punktzahl, wenn während des automatischen Bewertungsprozesses keine Fehler auftreten, andernfalls werden null Punkte vergeben.

Die Zellen sind für Studierende schreibgeschützt. Dies ist wichtig, damit die Zellen später nicht von Studierenden aus dem Notebook gelöscht oder verändert werden.

Tests in „Autograder-Tests“-Zellen können durch die Verwendung einer speziellen Syntax versteckt werden, z.B. ### BEGIN HIDDEN TESTS und ### END HIDDEN TESTS:

Bild: 17 Beispiel: „Autograder-Tests“-Zelle

Bei der Erstellung der Release-Version (die die Studierenden bearbeiten) wird der Bereich zwischen den Zeilen mit der speziellen Syntax entfernt. Wenn diese spezielle Syntax nicht verwendet wird, wird der gesamte Inhalt der Zelle angezeigt und die Testzelle ist für die Studierenden sichtbar.


„Read-only” Zellen

Wenn die Option „Read-only” gewählt wird (verfügbar für Code- und Markdown-Zellen), markiert dies Zellen als schreibgeschützt. Dies wird durch ein Schlosssymbol in der Zelle angezeigt.

Bild: 18 Read-only Zelle


Validieren der Aufgaben

Um sicherzustellen, ob alle Aufgaben korrekt sind und Studierende Aufgaben erhalten, die sie auch bestehen können, können die Aufgaben mit „Validate“ überprüft werden:

Bild: 19 Validieren der Aufgabe über die Toolbar

Wenn die Aufgaben die Überprüfung bestanden haben, erscheint folgendes Pop-Up:

Bild: 20 Pop up-Fenster nach dem Validieren

Wenn einer der Zellen Fehler enthält, erscheint eine Fehlermeldung, die auch angibt, wo der Fehler liegt:

Bild: 21 Fehlermeldung nach dem Validieren


Generieren einer Aufgabe

Nachdem ein Notebook erstellt wurde, in dem die Zellen mittels der „Create assignment“-Toolbar als Aufgaben markiert wurden, muss die Version generiert werden, die die Studierenden erhalten. Dies kann mit einem Klick auf das Icon „Generate“ in der „Managing Assignments“ Übersicht realisiert werden.

Bild: 22 Icon zum Generieren von Aufgaben in der "Manage Assignments" Übersicht

Daraufhin erscheint folgendes Fenster, welches das erfolgreiche Generieren der Aufgabe anzeigt:

Bild: 23 Pop up-Fenster nach erfolgreichem Generieren einer Aufgabe


Vorschau der Studierendenversion

Nach dem Erstellen der Studierendenversion der Aufgabe (siehe Generieren einer Aufgabe), kann eine Vorschau angezeigt werden, um sicherzustellen, dass alle Aufgaben korrekt dargestellt werden. Die Vorschau kann mit einem Klick auf das Icon „Preview“ in der „Managing Assignments“ Übersicht angezeigt werden:

Bild: 24 Icon zur Vorschau von Aufgaben in der "Manage Assignments" Übersicht

Diese Version der Aufgabe liegt nun nicht mehr im Ordner source, sondern im Ordner release (im Verzeichnis des Kurses), der die aktuellen Versionen der Aufgabe enthält. Die Versionen in diesem Ordner sind die Aufgaben, die an die Studierenden weitergegeben werden.


Freigeben von Aufgaben

Um Aufgaben zu veröffentlichen und für Studierende freizugeben, muss auf das Icon bei „Release“ geklickt werden:

Bild: 25 Icon zum Veröffentlichen von Aufgaben in der "Manage Assignments" Übersicht

Um Aufgaben freigeben zu können, muss ein Kurs vorhanden sein, dem die Aufgabe zugewiesen werden kann (siehe Kurserstellung und Kursverwaltung).

Wenn die Freigabe einer Aufgabe rückgängig gemacht werden soll, kann erneut auf die Schaltfläche „Release“ geklickt werden (nach Freigabe ändert sich das Icon und zeigt nun ein „x“ ).
Hinweis: Allerdings sollte beachtet werden, dass Studierende, die die Aufgabe bereits heruntergeladen haben, weiterhin Zugriff auf ihre heruntergeladene Kopie haben. Wenn die Freigabe einer Aufgabe aufgehoben wird, wird lediglich verhindert, dass weitere Studierende die Aufgabe herunterladen können.


Bewerten von Aufgaben

Da die Jupyter-Erweiterung Formgrader nur lokal für Lehrende läuft, werden Aufgaben und deren Bewertung und Feedback nur lokal gespeichert. Daher ist keine Synchronisation zwischen mehreren Lehrenden möglich!
Hinweis: Erst nachdem die automatische Bewertung erfolgt ist, kann die manuelle Bewertung stattfinden.

Sammeln der Abgaben von Studierenden

Um Abgaben bewerten zu können, müssen zunächst alle Abgaben gesammelt werden. In der „Managing Assignments“ Übersicht können alle Abgaben gesammelt werden, indem auf das Icon „Collect“ geklickt wird:

Bild: 26 Icon zum Sammeln von Aufgaben in der "Manage Assignments" Übersicht

Nach Abschluss des Vorgangs wird ein Pop-up-Fenster angezeigt, welches unter anderem aufführt, wie viele Abgaben vorhanden sind.



Automatisches Bewerten

Sie können einzelne Abgaben direkt in Formgrader automatisch bewerten lassen. Klicken Sie dazu in der Ansicht „Managing Assignments“ auf die Anzahl der Abgaben:

Bild: 27 Anzahl von Abgaben in der "Manage Assignments" Übersicht

Es öffnet sich eine neue Seite, die Übersicht „Manage Submissions“. Hier sind alle Abgaben gelistet. Der Status dieser Abgaben steht auf „needs autograding“.

Um eine Abgabe automatisch bewerten zu lassen, muss auf das Icon unter „Autograde“ geklickt werden:

Bild: 28 Bewertungsansicht „Manage Submissions“

Nach Abschluss der automatisierten Bewertung wird ein Popup-Fenster angezeigt:

Bild: 29 Pop up-Fenster nach erfolgreicher automatisierter Bewertung

Zurück in der Übersicht „Manage Submissions“ ist dann zu sehen, dass sich der Status der Abgabe in „needs manual grading“ geändert hat. Die durch das automatische Bewerten erreichte Punktzahl wird bereits angezeigt:

Bild: 30 Ergebnisse der automatischen Bewertung in der „Manage Submissions“-Übersicht

Zu diesem Zeitpunkt sind alle Zellen, die für das automatische Bewerten markiert wurden (Autograded Answer), bewertet. Erst nachdem die automatische Bewertung erfolgt ist, kann die manuelle Auswertung stattfinden.



Manuelles Bewerten von Aufgaben

Unter „Manual Grading“ können die Abgaben manuell bewertet werden. Dies betrifft vor allem die Zellen, die mit den Aufgabentypen „Manually graded answer“ und „Manually graded task“ markiert wurden.

Damit eine Abgabe manuell bewertet werden kann, muss die Aufgabe zuerst automatisch bewertet werden (siehe Automatisches Bewerten).

Im Tab „Manual Grading“ in Formgrader werden mit Klick auf den Namen der Aufgabe alle Abgaben angezeigt:

Bild: 31 Abgaben einer Aufgabe im "Manual Grading" Tab

In jeder Abgabe kann bei den manuell zu bewertenden Aufgaben die Punktzahl eingetragen werden. Zusätzlich können Kommentare hinzugefügt werden, die im Feedback angezeigt werden.

Bild: 32 Beispiel: Manuelles Bewerten einer Aufgabe

Nach dem automatischen und manuellen Bewerten wird die Abgabe als „graded“ markiert.

Bild: 33 Ansicht einer komplett bewerteten Aufgabe


Feedback zu Abgaben

Die Erstellung von Feedback für Studierende gliedert sich in zwei Teile:

  • Feedback generieren
  • Feedback veröffentlichen


Beim Generieren des Feedbacks werden HTML-Dateien im lokalen Verzeichnis des Lehrenden erstellt. Beim Freigeben des Feedbacks werden diese HTML-Dateien in den nbgrader-exchange kopiert und an die Studierenden freigegeben.

Um Feedback für alle Abgaben zu generieren und für alle Studierenden freizugeben, kann in der „Manage Assignments“ Übersicht auf die Icons „Generate Feedback“ und „Release Feedback“ geklickt werden:

Bild: 34 Generieren von Feedback für alle Abgaben

In der „Managing Submissions“ Übersicht kann auch zu einzelnen Aufgaben Feedback gegeben werden:

Bild: 35 Generieren von Feedback für alle Abgaben


Der Tab „Manage Students“


Hier wird eine Liste aller Studierender des Kurses angezeigt.
Wichtig:

Siehe auch


Bei Fragen oder Problemen wenden Sie sich bitte telefonisch oder per E-Mail an uns:

Tel. IT: +49 (5251) 60-5544 Tel. Medien: +49 (5251) 60-2821 E-Mail: imt@uni-paderborn.de

Der Servicepoint ist aktuell im Notebook-Café zu finden

Das IMT:Notebook-Café (Raum I0.401) bietet in der vorlesungsfreien Zeit nur eingeschränkten Support und hat von Montag bis Donnerstag von 08:30 - 16:00 Uhr und Freitags von 8:30 Uhr bis 14 Uhr für Sie geöffnet geöffnet. Telefon- und E-Mailsupport erfolgt Montag bis Donnerstag von 8:30 Uhr bis 16 Uhr und Freitag von 8:30 Uhr bis 14 Uhr.


Das IMT:Servicecenter Medien auf H1 hat aktuell von Montag bis Donnerstag von 8:00 - 16:00 Uhr und am Freitag von 8:00 - 14:30 Uhr geöffnet.